
Converting MacNail to
Goldenseal

These instructions cover the one-time conversion of MacNail
accounting and unit price data into Goldenseal.

A separate manual covers the import of MacNail and BidMagic
estimates into Goldenseal.

The first section of these instructions gives a quick overview of
how the conversion works.

The remaining sections cover the conversion in more detail.

Conversion Basics
Goldenseal includes a utility program that processes MacNail data so it can
be imported into Goldenseal.

The following information can be imported from MacNail when you first
start using Goldenseal:

• Accounts
• Unit Costs and Contract Info
• Job Cost Transactions

Installing

Before using the converter, move the following three items so they are
inside your MacNail folder.

• MacNail-Goldenseal Converter
• Conversion Blanks folder
• Converted Files folder

You should put the three items into the same folder as your Accounts,
Estimates and other MacNail folders, but not inside any of the other
MacNail folders.

If you use MacNail Estimating, also put the Estimating Manager 3.5 into
your Estimates folder, and remove any older versions of the Estimating
Manager.

How to Convert Your Data

Use the MacNail-Goldenseal Converter to convert data from MacNail to
Goldenseal. It is a macro sheet, similar to the Estimating Manager,



Accounting Manager and other MacNail Managers.

Converting Accounting Data

To convert your MacNail Accounting data so it can be imported into
Goldenseal, follow these steps:

1. Decide which files you want to move into Goldenseal. If there are
some files you don’t want to include, temporarily move them out of the
MacNail folders.  If there are files you want to include that aren’t now in
the MacNail folders, temporarily move them there.
2. Double-click on the MacNail-Goldenseal Converter icon to open the
conversion utility. After you have opened it, you will see a Convert
menu to the right of the regular Excel menus.
3. Choose Initial Setup from the Convert menu.  It will take a few
minutes to set up a support file that lists all the accounts that you use.
4. Check the Validation file— it will tell you if there is any data that will
have problems being converted. If necessary, fix any problems in your
data before you continue.
5. Check the Initial Setup file. It is a list of all the accounts that you use.
You can delete any obsolete accounts, change category systems, or
otherwise tidy up the data before it is imported.
6. Choose Job Cost Options from the Convert menu. If you have been
using Labor Logs to track labor costs, turn on the checkbox next to Labor
From Log. If you have been entering labor costs directly into a checkbook
ledger, turn the checkbox off.  Do the same things for material,
subcontractor and miscellaneous costs, then click OK.
7. Choose Convert Accounting Files.  It will take a few minutes to
convert all of the accounts, ledgers and logs into a format that can be
used by Goldenseal.

HINT: If you want to convert just some of your files, or if the full
conversion doesn’t work due to memory limitations, you can also do
the conversion in separate steps, as described later in these
instructions.

8. Switch to Goldenseal, and create a company file. For instructions in
starting with Goldenseal, check the Getting Started manual.
8. Choose Import from the File menu, and choose Company File from
the submenu.
9. Navigate to the Converted Files folder, and open the MacNail
Accounts file.
9. All of your project, overhead, checking, employee, material,
subcontractor and other cost accounts will be imported automatically.
10. In Goldenseal, check each of the new accounts and finish setting
them up. You’ll need to create sales tax rates, payroll taxes, billing rates
and a few other items, and then assign them to each account.



11. When you’ve finished setting up your accounts, choose Import from
the File menu again, and choose Company File from the submenu.
12. Navigate to the Converted Files folder, and open the MacNail
Transactions file.
13. All of your checking transactions and labor, material, subcontractor
and miscellaneous logs will be imported.

Converting Unit Costs

Goldenseal already includes the basic MacNail unit prices that come with
the program. If you have not made many changes to the MacNail prices,
you don’t need to do anything.

If you have created your own unit prices or made other changes to the unit
prices that come with MacNail, you may want to bring in your current data.

To convert MacNail unit costs, follow these steps:
1. Double-click on the MacNail-Goldenseal Converter icon to open the
conversion utility.
2. Choose Convert Customizing Unit Prices.  It will take a few minutes to
convert all of the unit prices and assemblies that you have created.
3. Switch to Goldenseal, and open a company file.
4. Choose Import from the File menu, and choose Company File from
the submenu.
5. Navigate to the Converted Files folder, and open the Unit Price Data
file that includes today’s date.
6. All MacNail cost data will be imported automatically.

Possible Problems

If you have a large amount of data, you may have problems merging it all
into one company file.

To improve your chances of successfully handling large amounts of data,
try either of the following:

• Quit from Excel and try again. Sometimes its memory becomes
fragmented, especially after performing the complex operations needed
in the preparation steps.
• Give Excel more memory. To do so, Quit from Excel, select the Excel
program icon, choose Get Info from the File menu, and increase the
memory values in the lower right corner of the box.

Preparing MacNail Data
Before you convert your MacNail data to Goldenseal, it’s a good idea to
review your records and make a decision on what to move into the new
program.



What Can Be Moved

All account data that is stored in the Master Index and Master Addresses
files can be brought into MacNail.

All unit cost data can be imported— including material and labor costs,
assembly information, reminders and contract details from the SpecWriter.

Job cost transactions from Ledgers and Logs can also be imported. Because
the transactions do not have offsetting payments, they will be marked as
‘Job Cost Only’ in Goldenseal.  They will be used to figure job costs, but they
won’t be included in accounts payable or payroll calculations and they
won’t affect account balances.

NOTE: If you import active transactions that should be included in
payables or payroll, you can change their status in Goldenseal after they
have been imported. Goldenseal will ‘post’ the items when you make
the status change.

File Preparation

The conversion utility converts all MacNail Ledger and Log files that are
found in the Current Accounts folder.

If you only want to move some of your data, temporarily remove the files
that you do not want to be moved to Goldenseal.

If you have older files that you want to move into Goldenseal , make sure
that they are located inside the Current Accounts file.

If you want to move only some data from a file, follow these steps:
1. Make a backup copy of the file.
2. Put the original file into the Current Accounts file.
3. Open the file using the MacNail Accounting Manager.
4. Clear or delete the rows that you don’t want to convert.
5. Run the full conversion to Goldenseal.
6. Replace the original file with the complete backup copy that you made
in step 1.

Preparing Ledgers

Quick Ledgers cannot be converted to Goldenseal, since they don’t have job
cost information or payee lookups. The conversion program will
automatically skip them.

Payouts will be imported only if there is an account from the Master Index
listed in the pay to column. If the pay to column is blank or if an unlisted
account is there, you can either fill in a value before doing the conversion,
or add that transaction within Goldenseal after the conversion is made.

Deposits will be imported only if there is an account listed in either the job



or pay to column. That account will be considered to be the source of the
funds that were deposited.

If the check number column is a number, the transaction will be entered as
a Bank Check.  If it is not a number, the transaction will be entered as a
Bank Transfer Out.

Split payments (two items with the same check number) will be entered as
two separate transactions.

Items that have ‘cash’ in the check number column will be added as Cash
transactions in Goldenseal. Everything else will be entered as a Checking
transaction..

File Validation

The conversion utility includes a setup command that prepares account
information and validates the accuracy of your files. You must run the
setup as the first step in converting data from MacNail.

To run the setup, follow these steps:
1. Prepare your files as described in the previous section.
2. Open the MacNail-Goldenseal Converter file.
3. Choose Initial Setup from the Convert menu.
4. You’ll see a dialog that allows you to control what is done in the setup.
For best results, turn on all of the validation options.
5. Click OK. The setup utility will open all of your MacNail files and
check them- it may take a while to run.  The setup utility will change the
text of problem rows to bold/italic, but will not otherwise affect your
data.
6. When the setup utility is finished, check the setup file reports, and
make sure that all problems are corrected before finishing the
conversion.

Checking the Validation File

If you turn on one or both of the ‘Check for Valid Accounts’ options in the
setup, a Validation file will be created that shows any problem that were
encountered.



The Validation file lists all of the available files in the Current Accounts
folder, along with the number of problem rows that were found in each
file.

Problems may be either payee names that aren’t in the Master Index, or job
names that aren’t in the Master Index.

If you open the files, rows with bad payee or job names will have the
names marked in bold italic.

To make sure those items are converted successfully, you’ll need to add the
payees or jobs to the Master Index file. To do so, follow these steps:

1. Open the MacNail Accounting Manager, so menu commands will be
available.
2. Open the Master Index.
3. Type in new names under the Labor, Material, Other, Subcontractor or
Job columns.
4. Open the problem Ledger or Log file, and select any cell in each row
that has a problem. You can drag through multiple rows at a time.
5. Choose Lookup Formulas from the Formula menu (View menu in
later Excel versions). When asked whether to restore lookup formulas,
click OK.

NOTE: If there are already lookup formulas in the first row, you’ll be
asked whether to remove the formulas.  First remove them, then
choose Lookup Formulas a second time to restore them.

6. When you have finished adding items to the Master Index, run the
setup utility again.

Checking the Setup File

When you run the setup utility, the Converter will also create a setup file,
which lists all accounts that will be created in Goldenseal.



The setup
file lists all
account
names in the
first column,
the type of
account in
the second
column, the
account ID
number in
the third
column, and
additional information for some account types in the remaining columns.

Generally you do not need to do anything with the setup file. However if
you want, you can change file types, account ID numbers or category
systems before making the conversion.

Changing File Types

Most job accounts are listed as Project Accounts, but jobs that use the Office
Cost Control file are listed as Overhead Accounts.

To change the type of account that will be created for a job, follow these
steps:

1. Select a cell that contains the type of job you want.
2. Choose Copy from the Edit menu.
3. Select the cell you want to change.
4. Choose Paste from the Edit menu.

If no cells already contain the desired job type, you can also type in either
Project Account<39> or Overhead Account<52>. The number and
surrounding <> symbols are important, since the import into Goldenseal
uses that class ID number to determine which type of account to create.

Changing Account ID Numbers

Each account is assigned an object id number in the setup file. These
numbers are what will identify each account within the transactions in
your ledgers and logs.

When you actually start work in Goldenseal, you’ll be able to refer to
accounts by name, choosing them from popup menus or clairvoyant lists.
There is no need to remember numbers as was done in MacNail. Because
you won’t directly interact with the object ID numbers, there’s no need to
have anything other than simple, sequential object ID numbers for your
accounts. That is what will automatically be assigned when you run the
setup.



If you feel you must use a different numbering system for accounts, you can
change the numbers in the setup file.  Simply retype the ID numbers before
you finish the conversion.

You must use positive integers (whole numbers greater than zero), and you
must be extremely careful not to use any duplicate numbers. If you do have
duplicates, the second account will be given a different number during the
Goldenseal import, and some transactions may then be assigned to the
wrong account.

Since the setup file is a ‘master list’ of all account ID numbers, you’ll need
to use it when doing any data conversions, later on.

Changing Category Systems

If you turn on the ‘Check Job Category Systems’ option in the setup,
category systems will automatically be retrieved for each job account, using
the original estimate or the cost control worksheet for that job.

For projects that do not include an estimate or cost control file, a default
value is used.

To change the category system that will be used for a job, follow these steps:
1. Select a cell that contains the type of category system you want.
2. Choose Copy from the Edit menu.
3. Select the cell you want to change.
4. Choose Paste from the Edit menu.

If no cells already contain the desired job type, you can also type in a
category system such as MacNail<2> or CSI<4>. The number and <>
symbols are important, since that is the class ID that determines the type of
category system that will be used.

See the next section for more about category systems.

Preparing Category Systems

Goldenseal comes complete with eight ‘stock’ category systems,
corresponding to the category systems used in the ‘stock’ versions of
MacNail.

As is the case with every account and transaction in Goldenseal, each
category system has a name and ID number.

The stock category systems are:
• A blank system with no categories (listed in the setup file as No
Category<1>)
• MacNail categories with subcategories, as used in the MacNail
Estimator and 2-layer MacNail cost control sheets (listed as MacNail<2>)



• CSI categories with subcategories, as used in the CSI Estimator and 2-
layer CSI cost control sheets (listed as CSI<3>)
• MacNail categories without subcategories, as used in the Short
MacNail Estimator and 1-layer MacNail cost control sheets (listed as
Short MacNail<4>)
• CSI categories without subcategories, as used in the Short CSI Estimator
and 1-layer CSI cost control sheets (listed as Short CSI<5>)
• Office cost categories, as used in the Office Cost Control sheet (listed as
Overhead<6>)
• Material cost categories, as used in the MacNail Price sheet (listed as
Materials<7>)
• Paint and Drywall cost categories, as used in the MacNail Paint
estimators (listed as Paint<8>)

If you use only the stock category systems, you won’t have to do anything
special when converting MacNail data. The conversion will automatically
check estimates or cost control worksheets, and use the correct category
system in Goldenseal.

Adding a Custom Category System

If you use a custom category system, you’ll need to add it to the setup files,
before converting other files that use it.

To add a custom category system, follow these steps:
1. Open the MacNail-Goldenseal Converter.
2. To get categories from an estimate, choose Category System from
Estimate from the Convert menu. To get categories from a job cost
control sheet, choose Category System from Cost Control from the
Convert menu.
3. The new custom category system will be added automatically.

Removing Excess Category Systems

For best results, do not remove any category systems before running the
data conversion.

After you have converted MacNail data into Goldenseal format, you can
remove any category systems that you don’t need. To do so, follow these
steps:

1. Open the Goldenseal file for your company.
2. Choose Cost Categories from from the Costs menu, and choose the
Category Systems submenu.
3. Click on an item you’d like to permanently delete.
4. Click the Delete button.
5. Repeat steps 3 and 4 for any other systems you’d like to delete.



A Note on Category System Numbering

Category Systems use reference numbers for each category and subcategory.
When the same reference numbers are used for two different items, it
allows two different systems to share some categories or subcategories
when reporting.

The MacNail and CSI subcategories are identical and use identical reference
numbers (between 101 and about 3000), even though they are arranged in
different categories.

MacNail categories use even 100’s from 100 to about 3000.  CSI categories
use even digits from 1 to 16.

Material categories (used in Cost Items) are in the 5000’s.

Paint categories range from 6000 into the 8000’s.

Office cost categories (used for Overhead costs) are in the 99000’s.

If you create your own category system, you can use any reference numbers
that you want.  Use duplicates of existing reference numbers if you will use
more than one category system, and want to share some categories.  Use an
independent number series if you want them to be listed entirely separately
in reports.

Preparing Estimates

No special preparation is needed for project estimates.

The automatic conversion process will use estimates only if they are listed
in the Master Index, and don’t have a Cost Control worksheet.

After you have set up Goldenseal , you can import any estimates.

Preparing the Master Index

The conversion creates Project and Overhead accounts from the Jobs
column in the Master Index. You’ll need to prepare the Master Index before
making the conversion, so it will know which projects to convert into
Overhead accounts.

Preparing Job Accounts

To prepare jobs for conversion, follow these steps:
1. Clear the names of any jobs that you don’t want converted.
2. Check for spelling mistakes and duplicates.

HINT: If you miss any mistakes, you can change them in Goldenseal
after you’ve run the import.

3. Identify Overhead accounts by changing the job names to bold. If there



is no estimate or cost control sheet for a job or if the ‘Check Job Category
Systems’ option is not used, a job will be converted to an Overhead
account if its name is in bold.  All other jobs will be converted to Project
accounts.

The conversion only moves the short project name from the Master Index.
You’ll need to add further information to your job accounts after you have
imported data into Goldenseal.

Preparing Cost Accounts

The conversion automatically creates Employee, Material, Subcontractor
and Other cost accounts from the Master Index.

It will use the names in the Master Index as the ‘short’ account names that
are used in menus. For Employees, withholding information is also used.

If you created a Master Addresses file, it will be checked for ‘full’ account
names, addresses and tax numbers.

After you have imported data into Goldenseal, add any further
information about each of your cost accounts.

Preparing Ledgers and Logs

The conversion from MacNail to Goldenseal will include all items in all
files in the Current Accounts folder.

If there are some files you do not want to include, remove them from the
Current Accounts folder before running the conversion.

If there are some items in some files that you do not want to include, clear
or delete them before running the conversion. You may want to work with
a copy of the original data file, so your original data remains intact.

All cost transactions must have a valid payee account name in the who
column. If some items have a name there that is not in the master index,
those items will not be converted.

To make sure a payment can be converted, follow these steps:
1. Make sure you are running the MacNail Accounting Manager.
2. Click on any cell in the row that has a payee that is not in the Master
index.
3. Choose Lookup Formulas from the Formula or View menu, and add
lookup formulas to the row.
4. Switch to the Master Index, and add the payee.
5. Switch back to the Ledger or Log, and enter the payee’s number in the
emp# or biz# column.
6. The new account name should appear in the who column.



Preparing Unit Cost Info

No special preparation is needed for unit cost information.

Running the Conversion
Once you have set up properly, it is easy to convert data from MacNail to
Goldenseal.

Converting Accounting Data

To convert accounting data from MacNail to Goldenseal, follow these steps:
1. Open the MacNail-Goldenseal Converter.
2. Choose Convert Accounting Data from the Convert menu.

You can also convert just one type of MacNail file by choosing Checkbooks,
Labor Logs, Material Logs, Subcontractor Logs or Misc Logs from the
Convert menu.

The conversion will put all MacNail accounting information into a file
that Goldenseal can import- the file will be located in the Converted Files
folder.

Converting Unit Cost Data

To convert unit cost data from MacNail to Goldenseal, follow these steps:
1. Open the MacNail-Goldenseal Converter.
2. Choose Convert Unit Costs from the Convert menu.

The conversion will put all MacNail accounting information into a file
that Goldenseal can import- the file will be located in the Converted Files
folder.

Importing into Goldenseal

To import converted data into Goldenseal, follow these steps:
1. Open a Goldenseal company file, or create a new one.
2. Choose Import from the File menu, and choose Company File from
the submenu.
3. Navigate to your MacNail folder, and open the Converted Files folder.
4. Select the file that was created by the Converter, and click Open.


